Taylor & Francis Online won’t work in IE versions 10 or earlier after upgrade on January 31

News

Tomorrow, January 31, providers using Atypon’s Literatum websites (including Taylor and Francis) will be implementing an enhanced level of web security (TLS or Transport Layer Security). This will mean no change for patrons using Chrome, Firefox and IE11 browsers. However, anyone using Internet Explorer 8, 9 and 10 will receive an error message. Taylor and Francis is advising patrons using earlier versions of Internet Explorer to upgrade to IE11 which fully supports TLS.