Google Chrome: Vulnerability discovered; users advised to update to latest version

News

Published: 8Mar2019

A vulnerability has recently been discovered in Google Chrome, which could allow attackers to remotely take control of users’ computers. If you use the Google Chrome browser, you are strongly advised to update to the latest version. For instructions on how to do so, visit Google’s support page Update Google Chrome.